Help needed with wine kit

Help Support The HomeBrew Forum:

mac1611

Active Member
Joined
Feb 24, 2021
Messages
78
Reaction score
24
been fermenting MYO red kit ,which Ive done loads of times ,however this one is being a bit stuborn .After 6 days of vigorous fermenting it stopped . but no way was it ready .I opened the lid and it was reading 1080. Istirred it up and removed some of the scum and it started fermenting again but after 10 days it stuck again this time 1020 .Any idea how to get it going again .Iv emade loads of these kits and never had a problem temp was a a steady 24 degrees .Any tips greatly appreciated
 

soupdragon

Senior Member
Joined
Feb 22, 2010
Messages
913
Reaction score
216
Location
Wallasey
If it's definitely stuck? Then I would recommend a restart yeast. Don't know if there's anything different about it from std yeast but it got a Cellar 7 kit going again for me that had stuck. I used the one from Crossmyloof. There's usage instructions on the site, pretty easy to follow.
Good luck.

Cheers Tom
 

johncrobinson

Landlord.
Joined
Sep 13, 2019
Messages
1,954
Reaction score
931
Location
Highlands
Something a bit odd here,After six days of vigorous ferment the gravity was 1080.
That figure as a STARTING gravity would give an abv of about 11.4% .

Normally the first 6 days would see a huge drop in gravity,ie. I would expect to see a reading of 1020 or less after 6 days NOT 1080.

As a first step test your hydrometer in plain water at about the same temp as your wine It should read 1000.

I know you are not a raw beginner but your readings seem very odd.:?:
 

mac1611

Active Member
Joined
Feb 24, 2021
Messages
78
Reaction score
24
Something a bit odd here,After six days of vigorous ferment the gravity was 1080.
That figure as a STARTING gravity would give an abv of about 11.4% .

Normally the first 6 days would see a huge drop in gravity,ie. I would expect to see a reading of 1020 or less after 6 days NOT 1080.

As a first step test your hydrometer in plain water at about the same temp as your wine It should read 1000.

I know you are not a raw beginner but your readings seem very odd.:?:
Yes thats what I dont understand ?? Will test my hydrometer !!
 

mac1611

Active Member
Joined
Feb 24, 2021
Messages
78
Reaction score
24
been fermenting MYO red kit ,which Ive done loads of times ,however this one is being a bit stuborn .After 6 days of vigorous fermenting it stopped . but no way was it ready .I opened the lid and it was reading 1080. Istirred it up and removed some of the scum and it started fermenting again but after 10 days it stuck again this time 1020 .Any idea how to get it going again .Iv emade loads of these kits and never had a problem temp was a a steady 24 degrees .Any tips greatly appreciated
Yes thats what I dont understand ?? Will test my hydrometer !!
Next time I read my hydrometer I will put on my reading specs !! it wasnt 1080 it was 1030 !! Sorry senior moment .Update stirred it all up and its starting to ferment again so fingers crossed
 

johncrobinson

Landlord.
Joined
Sep 13, 2019
Messages
1,954
Reaction score
931
Location
Highlands
Some having loads of different scales on them confuses things as well.
The last time I heard about degrees Twadlle was from my long deceased Grandfather a professional distiller.
 

mac1611

Active Member
Joined
Feb 24, 2021
Messages
78
Reaction score
24
Eventually got there with this kit .Really odd the fermenting just stopped couple of times ,but when I opened the lid and stirred it ,it started again ?? never had that before
 
Top