Kegland n2/CO2 potential issue

The Homebrew Forum

Help Support The Homebrew Forum:

Brewmastermk

New Member
Joined
Jan 15, 2022
Messages
17
Reaction score
8
I gave a potential issue with my 4 month old kegland n2/CO2 reg. hoping someone can offer some advice.

Generally it’s working well. I only connect it to the keg when dispensing and similarly only turn on the cylinder when dispensing. Running about 50psi on the stout.

My concern is that the high pressure side is leaking slightly. If I disconnect from the keg, pressurise the lines, I get say 1500psi cylinder side and 50psi keg side. If I then turn the cylinder valve off, over the course of a couple of hours the high pressure will drop to zero.
Is that normal?

All connectors are as tight as I can get them, no audible hiss and I can’t get any result on connectors with a bubble solution.

I want to have a freezer setup or similar so would quite like to know I can hook up the nitrogen and leave it Live without it just peeing out into the atmosphere…

Does it sound like the regulator might by faulty or leaking to you? They are cheap after all.

Thanks in advance,
Mark
 
Joined
Apr 4, 2021
Messages
302
Reaction score
135
Are you not worried that the cylinder is slowly leaking gas or do you think it’s slow enough it doesn’t matter?
I'm not sure it's leaking at all, I'm not familiar how does the regulator working exactly, maybe there are losses.
Imagine when you close the tap it's only measuring the pressure in that short pipe, which connect to the cylinder.
You can test for leaks with shaving gel as well, a bit better method than the soapy water.
 

Latest posts

Top